読者です 読者をやめる 読者になる 読者になる

Redmineインストール

昔インストールしたRedmineのバージョンが1.xでした。
が、2.3.2がリリースされているみたいなので、それをインストールして使うことにしました。
基本的にRedmine.JP Blogの手順で進めていきました。
が、いくつか詰まった箇所があったのでメモしておきます。

環境

詰まった箇所

基本的には手順参考を見て進めました。が、詰まりました。
詰まった点は、

  • bundlerのインストール・・・(ア)
  • Redmineの初期設定とデータベースのテーブル作成・・・(イ)
  • PassengerのApache用モジュールのインストール・・・(ウ)
  • Apache上のPassengerでRedmineを実行するための設定・・・(エ)

です。

(ア)

(A)のコマンドを打つとエラーが出ました。
エラーメッセージを元にグーグル先生に相談していたところ、(B)を見つけました。
ここで書かれているlibyaml-develのインストールは(A)でもやっているんですよね。
いろいろ試した結果、libyaml-develをインストールする前にrvmでRubyをインストールしていたのがよくなかったみたいです。((A)ではRubyのインストール前にlibyaml-develをインストールしています)

$ rvm remove 1.9.3
$ yum install libyaml-devel
$ rvm install ruby-1.9.3
$ gem install bundler --no-rdoc --no-ri
(イ)

この実行でエラーが出てしまいました。

$ RAILS_ENV=production bundle exec rake db:migrate

原因は、config/database.ymlの内容を書き間違えていたことでした。
はぁ・・・

(ウ)

この実行でエラーが出ました。

$ passenger-install-apache2-module

wrapper scriptsが古いよと。かなり悩まされました。
解決するために(E)(F)を参考に、いろいろやってみましたが、おそらく(D)の中段に書かれているこれをやればよかったのかなと思っています。
はっきりとした原因は分かりません。

cd /home/srcnix/.rvm/gems/ruby-2.0.0-p0/bin/
./passenger-install-apache2-module

(A)にはpassenger-install-apache2-moduleコマンドを実行するような書き方でしたが、passenger-install-apache2-moduleがあるディレクトリに移動して、上記のように実行するとうまくいきました。

(エ)

よっしゃインストールできた!と思って、ブラウザからアクセスすると・・・
"・・・SpawnPreparer/" : Permission denied と表示される・・・
ホームディレクトリのパーミッションが原因でした。
(G)のStep3:loosen permissionsにより解決。

感想

めっちゃ時間かかりました。
このRedmineによって土日の作業が効率的になるといいのですが・・・なるはず!

その他

YAPC::Asia Tokyo 2013、20,21日どちらも見に行きます!